正点财经首页     加入收藏
指标首页 通达信指标 同花顺指标 大智慧指标 飞狐指标 指标教程 指标实战 指标百科 股市学院
指标源码搜索: 热词:买卖  黑马  K线  牛股  量能  波段  顶底  抄底  成本  逃顶  MACD  涨停  换手率
你的位置: > 正点财经 > 炒股指标公式 > 同花顺指标公式 > 同花顺自用经典MACD图解指标公式

同花顺自用经典MACD图解指标公式

同花顺指标公式源码概况:
  • 指标类别: 同花顺指标公式
  • 授权方式: 免费版
  • 指标评级: ★★★★★
  • 指标分类: 趋势
  • 画线方法: 副图
  • 日期:2019-09-24 来源:互联网
同花顺指标公式源码介绍:

同花顺自用经典MACD图解指标公式:

DRAWGBKLAST(C>0,STRIP(RGB(145,145,185),RGB(140,140,180),1));
N1:=10; N2:=22; M:=7.5;
DIF:(EMA(C,N1)-EMA(C,N2))/(1+EMA(ABS(C),512))*7.5,COLOR0000FF;
DEA:EMA(DIF,M),COLOR09FFFF;
MACD:=2*(DIF-DEA),COLORSTICK;
PARTLINE(DIF,DIF>=REF(DIF,1),RGB(250,0,0),DIF<REF(DIF,1),RGB(0,0,250)),linethick1;
均衡:SMA(DIF,4,2),Color00FF00,LINETHICK1;
随行:IF(MACD< 0,MACD,0),ColorFFFFFF,LINETHICK1;
D2:=MACD;
STICKLINE(D2<REF(D2,1)AND D2>0,0,D2,5,0),Color979700;
STICKLINE(D2<REF(D2,1)AND D2>0,0,D2,4,0),ColorB5B500;
STICKLINE(D2<REF(D2,1)AND D2>0,0,D2,3,0),ColorD2D200;//兰
STICKLINE(D2<REF(D2,1)AND D2<0,0,D2,5,0),Color974B00;
STICKLINE(D2<REF(D2,1)AND D2<0,0,D2,4,0),ColorB55A00;
STICKLINE(D2<REF(D2,1)AND D2<0,0,D2,3,0),ColorD26900;//蓝
STICKLINE(D2>REF(D2,1)AND D2,0,D2,5,0),Color97004B;
STICKLINE(D2>REF(D2,1)AND D2,0,D2,4,0),ColorB5005A;
STICKLINE(D2>REF(D2,1)AND D2,0,D2,3,0),ColorD20069;//紫
STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,5,0),Color970097;
STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,4,0),ColorB500B5;
STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,3,0),ColorD200D2;//粉
VAR1:=(EMA(C,N1)-REF(EMA(C,N1),1))/REF(EMA(C,N1),1);
VAR2:=(EMA(C,N2)-REF(EMA(C,N2),1))/REF(EMA(C,N2),1);
STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,5,1),COLOR000066;
STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,4,1),COLOR000077;
STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,3,1),COLOR000099;
A:=MACD>0;
绿柱数:=BARSLAST(A)=5;
STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,5,0),COLOR00AA00;
STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,4,0),COLOR00CC00;
STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,3,0),COLOR00EE00;//绿柱
OSC:=100*(CLOSE-MA(CLOSE,11.5));
MAOSC:=EMA(OSC,4.5);
STICKLINE(MACD<REF(MACD,1)AND CROSS(MAOSC,OSC),0,MACD,5,0),COLORFF0000;
STICKLINE(MACD>REF(MACD,1)AND CROSS(OSC,MAOSC),0,MACD,5,0),COLOR09FFFF;

同花顺自用经典MACD图解指标公式实例图解:

同花顺自用经典MACD图解指标公式

  • 风云榜
  • 总点击榜
  • 最新指标
月点击榜指标公式
更多指标百科
关于我们 | 广告服务 | 联系方式 | 意见反馈 | 合作伙伴 | 法律声明 | 网站地图
正点财经网所载文章、数据等内容纯属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。
小米彩票手机官网 500万彩票开奖记录数据分析 吉林快3代理 500万彩票网 小米彩票登入 小米彩票娱乐 幸运时时彩 极速时时彩 福建11选5官网 一分时时彩