正点财经首页     加入收藏
指标首页 通达信指标 同花顺指标 大智慧指标 飞狐指标 指标教程 指标实战 指标百科 股市学院
指标源码搜索: 热词:买卖  黑马  K线  牛股  量能  波段  顶底  抄底  成本  逃顶  MACD  涨停  换手率
你的位置: > 正点财经 > 炒股指标公式 > 通达信指标公式 > 通达信MACDKDJRSI背离共振指标公式

通达信MACDKDJRSI背离共振指标公式

通达信指标公式源码概况:
  • 指标类别: 通达信指标公式
  • 授权方式: 免费版
  • 指标评级: ★★★★★
  • 指标分类: 超买超卖
  • 画线方法: 副图
  • 日期:2019-06-15 来源:互联网
通达信指标公式源码介绍:

通达信MACDKDJRSI背离共振指标公式:

{MA3:=MA(CLOSE,3);
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);
MA250:=MA(CLOSE,250); }
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
MACD底背:IF(B1>0,50,0) AND L-0.1;
DRAWTEXT(MACD底背,72,'MACDY底背');
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
KDJ底背:IF(B2>0,50,0) AND L-0.25;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
RSI底背:IF(B3>0,50,0) AND L-0.4;
全底背:IF(MACD底背 OR KDJ底背 OR RSI底背,50,0),COLORFF00FF;
DRAWTEXT(MACD底背,50,'M底背'),COLOR0000FF;
DRAWTEXT(KDJ底背,65,'K底背'),COLOR0000FF;
DRAWTEXT(RSI底背,80,'R底背'),COLOR0000FF;
DRAWTEXT(全底背,100,'全底背'),COLORYELLOW,LINETHICK2;
{--------------------}
趋势: 5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),LINETHICK0,COLOR7F52AF;
趋势1: EMA(MA(趋势,5),3),LINETHICK0,COLORA6B8C1;
STICKLINE(趋势>=趋势1,趋势,趋势1,5,0),COLOR7F52AF;
STICKLINE(趋势<趋势1,趋势,趋势1,5,0),COLORA6B8C1;
STICKLINE(趋势>108 AND 趋势>=趋势1,趋势,108,5,0),COLORFF0000;
STICKLINE(趋势1>108 AND 趋势<趋势1,趋势1,108,5,0),COLORFFFFFF;
STICKLINE(趋势<0 AND 趋势<趋势1,趋势,0,5,0),COLORF00FF0;
STICKLINE(趋势1<0 AND 趋势>趋势1,趋势1,0,5,0),COLORF0F000;
V1:= MA(CLOSE,5)=HHV(MA(CLOSE,5),20);
V2:= MA(CLOSE,5)>MA(CLOSE,20);
V3:= COUNT(MA(CLOSE,1)>REF(CLOSE,1),3)=3;
风险: IF(V1 AND V2 AND V3,30,0),LINETHICK0,STICK,COLOR00FF00;
V11:= MA(CLOSE,5)=HHV(MA(CLOSE,5),120);
V21:= MA(CLOSE,5)>MA(CLOSE,120);
V31:= COUNT(MA(CLOSE,1)>REF(CLOSE,1),3)=3;
风险1: IF(V11 AND V21 AND V31,60,0),LINETHICK0,STICK,COLORF0F000;
底部: 5,LINETHICK0,COLOR00FFFF;
抄底: IF(CROSS(趋势,底部),40,0),LINETHICK2,STICK,COLOR00FFFF;
DRAWTEXT(抄底,50,'抄底'),COLOR0000FF;
天线: 108,LINETHICK0,COLORFF9D00;
逃顶: IF(CROSS(天线,趋势),1,0),LINETHICK0,STICK,COLORFF9D00;
STICKLINE(CROSS(天线,趋势),90,108,3,0),COLORFF9D00;
DRAWTEXT(CROSS(天线,趋势),85,'逃顶'),COLORFF9D00;
DRAWTEXT(CROSS(天线,趋势),85,'逃顶'),COLORFF9D00;

通达信MACDKDJRSI背离共振指标公式实例图解:

通达信MACDKDJRSI背离共振指标公式

  • 风云榜
  • 总点击榜
  • 最新指标
月点击榜指标公式
更多指标百科
关于我们 | 广告服务 | 联系方式 | 意见反馈 | 合作伙伴 | 法律声明 | 网站地图
正点财经网所载文章、数据等内容纯属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。
鼎鑫彩票注册 迪士尼彩乐园娱乐 500万彩票 北京pk10 乐彩网导航 500万彩票 500万彩票登入 五分时时彩 王者彩票APP 上海11选5走势