正点财经首页     加入收藏
指标首页 通达信指标 同花顺指标 大智慧指标 飞狐指标 指标教程 指标实战 指标百科 股市学院
指标源码搜索: 热词:买卖  黑马  K线  牛股  量能  波段  顶底  抄底  成本  逃顶  MACD  涨停  换手率
你的位置: > 正点财经 > 炒股指标公式 > 通达信指标公式 > 通达信磁铁BS买卖指标公式

通达信磁铁BS买卖指标公式

通达信指标公式源码概况:
  • 指标类别: 通达信指标公式
  • 授权方式: 免费版
  • 指标评级: ★★★★★
  • 指标分类: 策略
  • 画线方法: 主图
  • 日期:2019-06-14 来源:互联网
通达信指标公式源码介绍:

通达信磁铁BS买卖指标公式:

JRH:=HHV(C,2);JRL:=LLV(C,2);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1 );
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:=IF((VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC),1,0);
青色观望:=IF((VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18),1,0);
短买:=VAR19;
品红离场:=VAR1A;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,1,0),COLOR858500;
STICKLINE(C>=O,C,O,1,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,4,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,4,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,4,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,3,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR0000EE;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000FF;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,2,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,2,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,2,0),COLOREEEE00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORFFFF00;
DRAWICON(短买,LOW-0.2,7);
DRAWICON(品红离场,HIGH+0.2,8);
RSV:=(C-LLV(L,15))/(HHV(H,16) - LLV(L,16))*100;
趋势:=MA((3*SMA(RSV,6,1)-2*SMA(SMA(RSV,5,1),5,1)),2),LINETHICK1,COLOR0000FF;
VAR42:=3*(SMA(((OPEN - LLV(LOW,82))/(HHV(HIGH,89) - LLV(LOW,89)))*(100),20,1))-2*(SMA(SMA(((OPEN - LLV(LOW,89))/(HHV(HIGH,89) - LLV(LOW,89)))*(100),20,1),15,1));
VAR43:=VAR42-100;
背离:=FORCAST(-1*VAR43,21),LINETHICK1,COLOR00FFF3;
GH:=SUM((H-L)/L*100,8)<16;
DRAWTEXT((CROSS(趋势,背离) AND 背离<85 ),LOW*0.88,'主升'),COLORE7FCB9;
乖离率:=(C-MA(C,30))/MA(C,30)*500;
N1:=BARSLAST(CROSS(C,MA(C,30)));
N2:=BARSLAST(CROSS(MA(C,30),C));
长期趋势:=IF(N1<N2,N1+1,0);
峰值乖离:=HHV(乖离率,长期趋势);
VAR25:=(EMA(CLOSE,2) - EMA(CLOSE,150));
VAR26:=EMA(VAR25,100);
VAR27:=(2 * (VAR25 - VAR26));
VAR28:=((POW(VAR27,3) * 0.1) + POW(VAR27,1));
黑马线:=(IF((VAR27 > 0.1),VAR28,0) * 5),COLORFF0000;
DRAWTEXT((CROSS(趋势,背离) AND 黑马线>0.9 AND (乖离率=峰值乖离) ),LOW*0.80,'黑马'),COLORMAGENTA;
顶压:HHV(MA(H,11),50),COLOR00FFFF;
短压:HHV(MA(H,11),15),COLOR0090E0;
XL1:=LLV(MA(H,11),1);
趋势2:IF(XL1>=短压,短压,XL1),COLORFFFFFF;

通达信磁铁BS买卖指标公式实例图解:

通达信磁铁BS买卖指标公式

  • 风云榜
  • 总点击榜
  • 最新指标
月点击榜指标公式
更多指标百科
关于我们 | 广告服务 | 联系方式 | 意见反馈 | 合作伙伴 | 法律声明 | 网站地图
正点财经网所载文章、数据等内容纯属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。
福建快3走势 北京pk10 500万彩票 贵州快3走势 大资本登录 小米彩票平台 荣鼎彩开奖 小米彩票主页 赖子棋牌 北京pk10