正点财经首页     加入收藏
指标首页 通达信指标 同花顺指标 大智慧指标 飞狐指标 指标教程 指标实战 指标百科 股市学院
指标源码搜索: 热词:买卖  黑马  K线  牛股  量能  波段  顶底  抄底  成本  逃顶  MACD  涨停  换手率
你的位置: > 正点财经 > 炒股指标公式 > 通达信指标公式 > 通达信MACD徐小明定量结构指标公式

通达信MACD徐小明定量结构指标公式

通达信指标公式源码概况:
  • 指标类别: 通达信指标公式
  • 授权方式: 免费版
  • 指标评级: ★★★★★
  • 指标分类: 趋势
  • 画线方法: 副图
  • 日期:2018-07-27 来源:互联网
通达信指标公式源码介绍:

      通达信MACD徐小明定量结构指标公式(分类:指标源码)通达信MACD定量结构指标是MACD称为指数平滑移动平均线,是从双指数移动平均线发展而来的,由快的指数移动平均线(EMA12)减去慢的指数移动平均线(EMA26)得到快线DIF,再用2×(快线DIF-DIF的9日加权移动均线DEA)得到MACD柱。

      通达信MACD定量结构指标使用说明:①股价新高或者新低,MACD指标中的DIF却未随之新高或新低,谓之“钝化”。 ②当钝化出现后,dif的值反向转折,谓之“结构形成”,此时应买入或卖出。dif的值在和前高或前低比较时,按照前极值的数量级,只比较前两位数字。

通达信MACD徐小明定量结构指标源码:
 
DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),LINETHICK2;
DEA:EMA(DIF,9),LINETHICK2,COLORRED;
MACD:(DIF-DEA)*2,COLORSTICK,LINETHICK3;
上翘:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORWHITE,LINETHICK2;
下拐:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORBLUE,LINETHICK2;
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,8,0),COLORRED;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'钝化'),COLORYELLOW;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(底背离消失,10),(DIF+MACD),'消失'),COLORGREEN;
STICKLINE(BG,0,(DIF+DEA),2,0), COLORRED;
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA),2,0), COLORGREEN;
STICKLINE(T OR TG,DIF,DEA,8,0),COLORGREEN;
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'结构形成'),COLORMAGENTA;
DRAWTEXT(FILTER(顶背离消失,20),(DIF+MACD),'消失'),COLORGREEN;
 

 

通达信MACD徐小明定量结构指标实战案例:
 
通达信MACD徐小明定量结构指标:
  科大讯飞(002230)是人工智能概念龙头,主营业务:主要由语音支撑软件、行业应用产品/系统、信息工程和运维服务。在2017年1月23日通达信MACD定量结构指标出现结构形成信号,后面七个交易日上涨10%。通达信MACD徐小明定量结构指标更新时间:2018-3-5 16:14

 

  • 风云榜
  • 总点击榜
  • 最新指标
月点击榜指标公式
更多指标百科
关于我们 | 广告服务 | 联系方式 | 意见反馈 | 合作伙伴 | 法律声明 | 网站地图
正点财经网所载文章、数据等内容纯属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。
500彩票网 北京pk10 幸运时时彩 亿信彩票导航 湖南快乐十分 大发时时彩 内蒙古快3 小米彩票导航网 99彩票网址多少 天津11选5