正点财经首页     加入收藏
指标首页 通达信指标 同花顺指标 大智慧指标 飞狐指标 指标教程 指标实战 指标百科 股市学院
指标源码搜索: 热词:买卖  黑马  K线  牛股  量能  波段  顶底  抄底  成本  逃顶  MACD  涨停  换手率
你的位置: > 正点财经 > 炒股指标公式 > 大智慧指标公式 > 大智慧RSI画线指标公式

大智慧RSI画线指标公式

大智慧指标公式源码概况:
  • 指标类别: 大智慧指标公式
  • 授权方式: 免费版
  • 指标评级: ★★★★★
  • 指标分类: 超买超卖
  • 画线方法: 副图
  • 日期:2019-04-28 来源:互联网
大智慧指标公式源码介绍:

大智慧RSI画线指标公式:含有未来函数

RSI:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100,COLORFF00FF,linethick2;
 RSI2:SMA(MAX(C-REF(C,1),0),90,1)/SMA(ABS(C-REF(C,1)),90,1)*100,COLORYELLOW,linethick2;
 A1:=REF(RSI,2)=HHV(RSI,2*2+1);
 B1:=FILTER(A1,2);
 C1:=BACKSET(B1,2+1);
 D1:=FILTER(C1,2);{高}
 A2:=REF(RSI,2)=LLV(RSI,2*2+1);
 B2:=FILTER(A2,2);
 C2:=BACKSET(B2,2+1);
 D2:=FILTER(C2,2);{低}
 H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
 L1:=(D2 AND NOT(D1));
 H2:=D1 AND NOT(D2);
 X1:=REF(BARSLAST(H1),1)+1;
 F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
 G1:=F1>REF(F1,1);
 I1:=BACKSET(G1,2);
 LD:=I1>REF(I1,1);{过滤后低点}
 L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
 X2:=REF(BARSLAST(L2),1)+1;
 F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
 G2:=F2>REF(F2,1);
 I2:=BACKSET(G2,2);
 HD:=I2>REF(I2,1);{过滤后高点}
 R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
 R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
 R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
 T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
 T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
 T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
 {-----------------【图解模板】---------------------}
 {DRAWGBK((DATE > 0),COLORRED(0,33,0),COLORRED(0,33,0),1);}
 压一:DRAWLINE(S2,RSI,S1,RSI,1),COLORRED; {压力1}
 压二:DRAWLINE(S3,RSI,S2,RSI,1),Color009AFF; {压力2}
 撑一:DRAWLINE(U2,RSI,U1,RSI,1),ColorFF68FF;{支撑1}
 撑二:DRAWLINE(U3,RSI,U2,RSI,1),ColorFFC800;{支撑2}
 {DRAWSL(U2,RSI,0,0,3),POINTDOT,ColorFFAFFF; }{启动直线}

{PARTLINE(C,RSI),COLORWHITE;}
 DRAWTEXT(cross(RSI,RSI2),RSI*0.98,'☆'),colorYELLOW;
 {海面:50,COLORWHITE;}
 准备:30,COLORRED;
 天边:80,COLORFFCC66,POINTDOT;
 海底:20,COLORFFCC66,POINTDOT;
 高位:70,COLOR00FF00;
 {DRAWTEXTABS(35,15,STKLABEL+' '+STKNAME),COLOR00FFFF;}
 DRAWTEXTREL(40,10,' 代码: '+STKLABEL+' '+STKNAME+' 日期: '+YEAR+'年'+MONTH+'月 '+DAY+'日 '),linethick1,ColorFFFF80;
 {5分钟小周期看背离}
 DRAWTEXTABS(15,120,'【5分钟小周期看背离】'),COLORFFFFFF;

大智慧RSI画线指标公式实例图解:

大智慧RSI画线指标公式

  • 风云榜
  • 总点击榜
  • 最新指标
月点击榜指标公式
更多指标百科
关于我们 | 广告服务 | 联系方式 | 意见反馈 | 合作伙伴 | 法律声明 | 网站地图
正点财经网所载文章、数据等内容纯属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。
大发时时彩 亿信彩票平台 河北快3开奖 大资本登录 江苏快3走势图 河北11选5走势图 极速时时彩 北京pk10 一分时时彩 幸运时时彩